OWC Announces Firmware Update For Industry-Leading Mercury Solid State Drive (SSD) Line

Other World Computing announced today it has released a new firmware version—MP5.0.1—to deliver optimum performance and stability from its industry-leading, SandForce Driven Mercury Solid State Drive line when installed in the latest Macs and PCs. The GUI driven, Mac experience friendly and bootable updater for Solid State Drives is freely available from OWC for use exclusively with OWC Mercury Extreme Pro, Mercury Electra, and Mercury Aura Pro SSD models.

The Only Mac Friendly Update Experience

OWC’s proprietary firmware updater, now available with support for all of Apple’s latest Mac models, as well as nearly all prior machines, eliminates the need for a PC, ownership of Windows or other operating system, or the creation of a specially designated drive partition that many SSD updaters have required. Mac users only need to download the updater from OWC’s site, obtain and burn a DVD, and then boot from that DVD to launch an easy to use, point and click GUI for installing the latest firmware revision to their OWC Mercury SSD. OWC’s Mac-friendly firmware updater continues OWC’s unmatched firmware update support for Mac users of SandForce-based SSDs. OWC also provides update support for PCs running the Windows or Linux OS.

We recognized SSDs would be an ever-evolving product, so we made it our priority to ensure users of OWC Mercury brand SSDs would immediately be able to utilize the benefit from any hardware and/or firmware updates,” said Larry O’Connor, Founder and CEO, Other World Computing. “As such, this latest firmware update is quick, easy and performed with no guesswork or doubt via the only point and click Mac-friendly updater; as well as standard upgrade packages for Windows and Linux Operating System users.”


LEAVE A COMMENT

  • Why not any updater from USB stick (memory) ??
    Most macbook air users does not got any CD player.

    Now I can’t update to new firmware.

    /Bosse




  • Hi, i’ve problem about to go in sleep mode with my macbook pro 3,1 (2,4GHz year 2007) with Mountain Lion 10.8.2 installed.
    After i’ve installed the ssd (OWC Mercury Electra 3g SSD) in the Superdrive bay, when i put the mac in sleep mode the light remains on not blinking, the monitor shut off and the system freeze without responding so that i’ve to restart the machine via power button.
    Do i need some firmware upgrade? My revision is: 504ABBF0. Can you drive me please to a solution to solve this problem?
    Thanks for you answer.




  • Model: OWC Mercury Electra Pro 3G SSD
    Revision: 501ABBF0

    I’m under the impression that there is a 502ABBF0 revision. Is that for me? Do I care?

    Thanks! :)




  • Downloaded, burned, booted, scanned for devices, found drive, clicked update…
    The updater tries for 20 seconds then fails with an unknown error…

    OWC Mercury EXTREME Pro 6G SSD:

    Capacity: 240.06 GB (240,057,409,536 bytes)
    Model: OWC Mercury EXTREME Pro 6G SSD
    Revision: 320ABBF0
    Serial Number: MX6G24011E29D8869
    Native Command Queuing: Yes
    Queue Depth: 32
    Removable Media: No
    Detachable Drive: No
    BSD Name: disk3
    Medium Type: Solid State
    TRIM Support: No
    Bay Name: Bay 1
    Partition Map Type: GPT (GUID Partition Table)
    S.M.A.R.T. status: Verified




    • Please contact our Technical Support department for assistance with troubleshooting via email, live chat, or phone at 1(800)275-4576.




      • I tried again today with the newest version of the updater and the firmware. Still no success.
        I thought maybe the Icy Dock was interfering because my drive reliability has been quite sporadic.
        But removing the Icy Dock and connecting my drive directly to bay 1 (Mac Pro 2008) made no difference.

        I’ve emailed tech support.




  • Hi I have a macbookpro 8.3 early 2011 17″ and with a datadoubler i have my OWC Extreme Pro 6G 240 gb in the hard drive bay . I downloaded the updater for 6g and burned iso to dvd then went into my macbookpro and removed datadoubler and reinstalled the optical drive …….
    booted off the dvd and when list come up for ssd drive to be updated it said “update not needed”. my current revision is 332ABBF0. I’m a pro user and would like to have my ssd up to date .. any fixes? …




  • Been having endless Sleep/Hibernation issues with my MBP 8,3 (Late 2011) and wondered if it could be related to OWC 6G SSD.

    Going to try this update out and see if it helps!




  • I have the Mercury Extreme Pro 6G in a 2011 MBP 8,2 running the firmware (311ABBF0). System is configured with win7/bootcamp. Followed the upgrade procedures for update instructions for a mac running bootcamp. ssdupdate.exe completes the update process with a green check mark. However after system reboot ssdupdate.exe firmware (311ABBF0).




  • Sharing my experience for the people that might be struggling with the OWC updater, when running it on a Mac Mini server 2009, seeing a dark and the blinking ‘_’:
    I have a Mac Mini Server , model 3,1 8 GB Ram, OS X Lion 10.7.3, internal SSD as start up disk, 2 TB through eSATA, display = Apple Cinema display connected on the Mini display port.
    Followed the instructions for burning the iso file and running the DVD on the external Apple USB DVD drive. When trying to update the firmware on a Mercury Electra 6G 60GB, I would get a blinking ‘_’ at the upper left corner and the computer would stay there indefinitely. After some hours of searching for a solution on the internet, I learned the OWC Ubuntu based updater, when running, does not recognize the Mini display port. I used the apple Mini DVI to DVI adapter and a DVI to HDMI connector in order to connect the Mac Mini to a TV display. Only then I was able to see the updater verbose and GUI and was able to update the firmware on the Mercury Electra 6G to the 501ABBF0.

    Additionally, I know the Mac Mini 3,1 SATA bus can only negotiate speed up to 3 Gbps, with the Mercury Electra 6G it could only negotiate 1.5 Gbps, even after resetting the PRAM and SMC. I had to go back to the 40 GB Mercury Extreme SSD in order to get the 3.0 Gbps as negotiated bus speed, I couldn’t then upgrade from 40 GB to 60 GB SSD.
    Can somebody advise if they experienced similar on the SATA bus from a late 2009 Mac mini server + a Mercury Electra 6G series SSD? and what they did in the case they went up to 3 Gbps bus speed?

    Thanks




  • An update to my various issues which prevented me from updating my Mercury Extreme Pro 6G:
    After various unsuccessful attempts, I resorted to sending my drive back to OWC under an RMA to get it updated. The service was quick (they shipped out a new updated drive the same day they received mine). Only downside is that since I received a new (blank) drive in return, it took a while to get it up and running using Lion Internet Recovery. But overall I am very happy with OWC’s service.




  • I’m not sure I understand why MacBook Pro users with DataDoubler have to reinstall their optical drive. There are plenty of bootable USB-based Linux distributions that don’t seemingly suffer from this problem. After having been promised last October an updater “in a few weeks” which would boot from USB or another internal partition, I was very disappointed to learn (through hours of experimenting), an external drive, UBS stick, FW drive, etc. are not available for applying this update. Can anyone give a clear explanation of this, and a pointer to workarounds that DO NOT involve spending several hours cracking the case and swapping drives?




    • It’s not an issue with the firmware updater itself, but rather how Apple handles boot support on some of their machines – namely the MacBook Pro 6,1 – 8,3 models. You cannot boot this updater via a USB or External Optical Drive. You will need to remove your Data Doubler and reinstall the factory optical drive to utilize this updater on those models.
      We are working on a solution and if we discover any workarounds, we’ll certainly promote them via a separate blog post.




  • Have Mac Mini 5.2 i7 2.7 with OWC Mercury Extreme Pro 6G 120GB.
    With external Apple DVD Drive updated my drive without any problems.
    Overall it took about 7 minutes from burning DVD to the end of update.
    After update boot time reduced in 2-3 seconds. Big THX, OWC!




  • Every day since I bought my HD have problems. First came with the HD defect. I had to pay the return shipping and all taxes when I got back from a failure of the employee who placed the OWC documentation for the custom house inside the box, where the tax has no access.

    I bought a MBP and a new Mercury Extreme SSD PRO HD 6G 240GB SSD. I switched the computer when the flaws identified by a new one. How did not solve the problem, I sent the HD to the OWC. Until you receive the product back two months have passed.

    It all started in November 2011, we are already in March 2012 and every day I need to connect and disconnect each 10x my computer until it recognizes the HD.

    I’ve tried several options: forums, Apple support, OWC support and so far my problem was not resolved.

    I await a solution or want the entire amount invested back.

    About my Mac:
    ============
    Model: MacBook Pro
    Model Identification: MacBookPro8,1
    Processor: Intel Core i5
    Memory: 8 GB
    ROM version: MBP81.0047.B27
    SMC version: 1.68f98

    About my SSD:
    ============
    OWC Mercury EXTREME Pro 6G SSD:
    Capacity: 240,06 GB (240.057.409.536 bytes)
    Model: OWC Mercury EXTREME Pro 6G SSD
    Revision: 501ABBF0
    Serial Number: MX6G24011E40F1943
    Native Command Queuing: Sim
    Profundidade da Fila: 32
    Mídia Removível: Não
    Unidade Removível: Não
    Nome BSD: disk0
    Tipo de Mídia: Estado Sólido
    Suporte do TRIM: Não
    Tipo de Mapa de Partição: GPT (Tabela de Partição GUID)
    Estado S.M.A.R.T.: Verificado




  • I have a 6,2 Macbook Pro with an OWC Electra 6G revision 319ABBF0. The updater tells me it can’t find an OWC SSD. I appear to meet the requirements though. Anyone else had this problem and solved it? Thanks.




  • Model Identifier: MacBookPro8,1
    Mercury ELECTRA 6G SSD:
    Revision: 319ABBF0

    I’m fine booting from the optical disc but when launching the updater can’t find the SSD.

    Any thoughts? Thanks in advanced.




  • I don’t think the Boot Camp idea would work unless there was an MBR partition/Boot Camp partition on the SSD being updated. I say this because I attempted to update my HDD the same way yet the firmware version remains the same… yet AGAIN.

    Now there are occasional blinking folder icon.. Now I’m not sure if this a MoBo problem for an SSD problem.




  • I took the SSD out of my 2011 MBP and placed it in another 2009-2010 MBP which had a CD internally. I booted from the CD drive but I only got a black screen and a blinking underline in the upper corner of the screen. I could also press a key when it began running (Ubuntu) and then I got a “Try Ubuntu before installing, Install etc – menu”.

    Unable to update it.

    Any idea whats going on?

    Another thing.

    Is it possible to put the SSD to be updated in a external housing and running the updater from another Mac with the SSD attached to that Mac? Is there a updater that can run from a Mac OS X computer and update a plugged in Mercury?




    • Please check the MacBook Pro mode identifier via the Apple Profiler and confirm you have downloaded the version correct for that model. There is one version for 2008 and early 2009 5,x models and then another version for pretty much everything else.

      http://eshop.macsales.com/tech_center/OWC/SSD/6G/Mac
      ===

      The SSD must be connected in an standard system SATA Bay (not external, etc) to be recognized for update.




    • The “try Ubuntu…” message appears if you boot from the DVD by pressing the ‘C’ key at boot time. I found this confusing too, but if you press the ‘option’ key instead at startup you’ll get the EFI boot screen where you can choose between startup disks. One will be your internal hard drive, and the other will have the CD icon named ‘windows’. Choosing the CD icon and hitting ‘Enter’ will boot the updater DVD correctly. Hope that helps.




  • After the firmware update to the Mercury Aura Pro Express 6G 240 GB in my late 2011 MBA 13″ 4,2 it now takes only 8 seconds from startup chime to log in screen whereas before it was 10 seconds. Thanx OWC!




  • Regarding speed incompatibility of 6g on late 2008 MBP – does your firmware update allows 6G to function on late 2008 MBP at full SATA revision II speed or 3G is still the only option to get 3Gps on late 2008 MBP? Thanks!




  • I too have a Data Double setup: my OWC 6G Pro SSD in the main location and a “free” Samsung 470 SSD in the optical bay. But I also have a Windows gaming PC that I built. Can I run the firmware updater from my PC with OS X as the only OS on the OWC SSD? Or because it’s a GUID drive, will it not work?




    • You certainly can remove the drive from your Mac, install it in your PC and run the PC Updater to update the SSD firmware. It shouldn’t affect the data on the drive one bit.
      That said, we highly suggest that you back up any data you don’t want to lose prior to performing any type of firmware update – better safe than sorry.




  • Does the Windows updater wotk with Vmware Fusion? Can the update be installed from Fusion?




  • The DVD boots fine, but your installer does not see my Mercury Extreme Pro. I have tried rebooting a couple of times but the installer still does not find any OWC drive during the scan. This is on a MacBook Pro 8.1. Current OWC firmware is 300ABBF0




  • Are there any release notes available of this new 501ABBF0 firmware?




  • Does this update have any performance update? I can switch my Mercury PRO 6G to another Mac to update. Would you reccomend it?

    Is this anything I will notice in performance and stability?




    • We do list the new firmware as ‘recommended’, the update is not critical. It mainly addresses stability of the drive on some installations and increased stability does allow for better performance.




  • I have the early 2011 Macbook Pro 13″ model. I had Apple replace a cable several months ago to see if it would fix the Sata 3 issue. It did not fix it for me. It actually made the SSD unbootable when they switched the cables out, when before it would boot but get beach balls regularly. So I can’t put the optical drive back in, since my SSD won’t work in the main bay’s port. (So I only get to use the Sata 3 drive with the optical bay’s Sata 2 port, which I have learned to live with, as its still fast).

    With that said though, I have Mac OSX Lion on both drives, my HDD and SSD. Can I use the installer on the HDD to then apply the firmware update on the SSD? Or can I use Windows via Parallels from the HDD to then apply it to the SSD?




    • If you have a Windows bootcamp volume on your hard drive, can boot that and use the windows updater.

      Otherwise – optical drive needs to be used to boot our Mac friendly updater with the SSD in the main laptop bay.

      Have never encountered 13″ that has a post EFI 2.2 Apple firmware update problem with 6Gb/s operation in the main bay that isn’t a bad cable… that suggests other issue fwiw… especially with the optical bay operating no problem with 6Gb/s (which is typical of 13″ with a handful of exceptions).

      Hopefully the bootcamp option is a viable option.




  • I just updated my Pro Extreme 6G that i’ve been having problems with. It was awkward getting the update in as i have an OptiBay (like a data doubler) installed with a 2nd hdd. In the end i had to put my drive in another macbook pro and update it using its drive.

    The update applied. Back into the original early 2011 17″ MacBook Pro. Booted nice.

    I went to try my 16gb of video files folder copy which i’d experienced a very occasional freeze, and corruption with before. Now sadly with this latest update its unusable. It took around 5 minutes to copy the 16gb onto the drive. So reading and writing maximum bandwidth. Lots of pauses, system hangs.. I then did my checksum tests and confirmed that 3 of my 6 files were corrupt. Previously with the older firmware i’d only managed a corruption once out of 10+ folder copies. I’d only had about 3-4 freezes in 2 weeks of getting the drive.. that’s hours of trying to stress it and no problems most of the time. Now as soon as i stress it its broken :(

    I’ve rebooted, the problem is still there. Basically its a write off. I’m wondering if the cable position may have changed as i’ve adjusted it.. I’m basically absolutely desperate for you guys to bring back your shielding kit, or recommend a material a bit safer than aluminium foil to try and run a DIY insulation job and see if it helps.

    Beyond this, i think its time i face facts, i’m not going to be able to get this SSD to work in my machine :(

    I brought from a UK reseller, so i guess i have to deal with them. I’ll be in touch with apple but doubt they’ll be able to offer a viable solution. I guess then i need to revert back down to an Electra 3G which should at least work ok!?!?

    Gutted, as the machine flies with this drive!!!




    • If EFI 2.2 or later installed (later versions don’t seem to affect 6Gb/s operation/stability past 2.2 – 2.2 and later all have the same affect vs. prior to 2.2) didn’t fix this issue + got the latest firmware, I’d really suspect there is something further wrong with the 6Gb/s port/signal that Apple’s 2.2 update wasn’t able to overcome. Electra 3G SSD will give you nearly the same performance for most operations but with 3G limitations. You may yet get a friendly local Apple service provider to swap what’s not so good.

      Feel free to ping us if need any assistance on exchanging.




      • Thanks Larry.

        I updated to the very latest EFI released a few days ago, last night. As expected it made no difference, as it wasn’t supposed to, according to the release notes.

        Whatever it is that you did in this new firmware update made my problem worse, but even before the problem was still there. To be honest being worse means at least that it’ll become easier to reproduce.

        I think i’m going to pick up some spare hdds and clone everything off again. This will let me reformat and go totally clean Lion install ready for potentially leaving with repair folks. I may try to get apple to swap it for a later 2011 model, if these are meant to be better with this whole SATA III thing.

        Beyond this i did have a brainwave, which is a bit counter intuitive but may be preferred to returning the SSD and exchanging for an Electra (btw is an Electra preferred to an older Pro Extreme 3G ? which you seem to no longer sell? is it just a rebadge to leave the pro extreme clear for the current top of the range models?). I can just swap my drives around and put my 6G SSD into the optical bay, the hdd in the standard bay. This way i SHOULD just sync at SATA II speeds and hopefully the problem will go away.

        Lots of choices, i definitely need to clone away my old macbook pro hdd incase i end up having to return/swap the machine. If i can clone away my current boot disk then i can test the SSD totally clean and ensure it still has a problem. I’ll presume it will have, I agree with you.. there is something left in some configurations that seem to be unfixable re: SATA III.

        I guess i’d be most annoyed if i got the late 2011 models and still experienced problems, its not impossible to think this could occur. I’ll presume late 2011 models aren’t totally guaranteed to be glitch free in this regard?

        Anyways, cheers. You guys have been nothing but helpful!!




        • Without any question Apple made significant improvements right out of the gate with the Late 2011 MacBook Pro models with respect to SATA 3.0 6Gb/s reliability. While Apple makes no guarantee for SATA 3.0 operation nor even lists SATA 3.0 as a supported specification, the later 2011 models definitely had improvements made which appear to be at a hardware level with respect to this… that compared to the earlier models that were an absolutely mess with SATA 3.0 before Apple utilized really ingenious software adjustments to overcome what we believe is inherently hardware related.

          Short answer is that the late models are solid as a rock (for main bay 6Gb/s).

          As for the Electra 3Gb/s. It has the same performance as the Electra 6Gb/s – but with the 3Gb/s ceiling. This is a step over and above the original Extreme Pro 3G model.




  • Does the burned disc need a name. I burned the .dmg to disc and it mounts as Untitled Disc.




  • I can confirm a successful firmware update of the Mercury Aura Pro Express 6G in my late 2011 MacBook Air 13″ 4,2 to 501ABBF0. Long download, but OK DVD burn & boot via key to Apple’s external USB superdrive for MBAir.




  • Maybe an obvious question: I have a Mercury Extreme (?) SSD and a recent Electra SSD (both 120GB) striped as RAID0. Will I be able to update both drives without any un-striping? I presume it will it detect the *drives* and not the *volumes*?




  • I asked about 3 months ago if there would be a updater for machines with data doublers and it was said to be in the making. Is there no way to update the drives with new firmware without taking the doubler out and installind the CD again?

    It kinda sucks to have this OWC itam in the machine and not be abled to update to improve stability etc.

    Common guys – figure it out!




    • It’s apple that makes the rules when it comes to boot support and presently there just aren’t options for our updater that can circumvent these rules without requiring you to own Windows OS. Right now you can install Windows on a partition and boot to that for these updates… but without requiring Windows to be owned, optical booting is the only option on these MacBook Pro models unfortunately at this time.




  • Data Doubler here too. MacBook Pro8.2 Electra 6G SSD

    OWC Michael you mentioned using windows updater via Bootcamp.

    Could someone at OWC write out the exact “How To” regarding this method.

    And post it on your page:

    http://eshop.macsales.com/tech_center/OWC/SSD/6G/Mac

    My revision is 320ABBF0 so I feel I need to update, but this would be a 1/2 day killer.




  • I can finally confirm a successful update of my OWC Mercury Electra 6G 480GB from 319ABBF0 to 501ABBF0 on my MacBook Pro 8,2 using the Mac updater. It took a while to download and literally 2 seconds to update.

    Great work OWC ;)




  • Wow, 800 MB that’s a big download. I’m getting like 100 kB/s. You should have put this thing on something like Amazon S3 so we can get decent download speeds.




  • well… Mac Mini 5,1 does not have an optical drive… and dont have an external one, >_< …..




  • The Windows updater detects my drive, the update appears to succeed, but when I re-run the scan, the drive still shows the old firmware version (330ABBF0).




  • It seems this only covers the 6G models, correct?




  • Any word on whether this update works with the very first batch of Mercury Extreme Pro 6G SSD’s (April 2011)? I ordered the 240gb the day it was available and have yet to download an updater that works. They all say “no OWC SSD is installed” whether i do it in Windows via Boot Camp or the Mac Updater before this one… Im still running RC firmware and would really appreciate an updated drive.




    • Just tried to update and it still didnt work. I took screen shots so if there is anyway i can get in contact with tech support i would really appreciate it.




      • Our Technical Support team would be happy to help troubleshoot. They are available at 1(800)275-4576, via email, or live chat




      • I’m in the same boat. I have the Mercury Extreme Pro 6G in a 2011 MBP 8,2running the original firmware (300ABBF0). The updater doesn’t seem to recognize that I have an OWC drive. I haven’t tried it on Windows since I don’t run Boot Camp, but I downloaded and burned the Mac updater ISO (owc6gfwup3.0c.iso) with no luck.

        If you figured out a way to do it, please post it here. It seems technical support is slammed right now…




        • I just got an email from tech support saying they acknowledge an issue with the current updater and the original firmware SSD’s. They say there is a new version which should work. I can’t confirm whether it does or not since I’ve already RMA’d my drive to get it updated by OWC, but I would suggest you email them to get the newer version of the updater.




  • So this is a new update only for 6G SSD; the links for the 3G indicate that the firmware is current as of Oct 20, 2011… is this correct?




  • Any info on what exactly this update fixes/improves? And thanks for now supporting 2011 MBP models!




    • It is a recommended update for stability & performance.




      • So I am trying to judge if the update is worth and hour or two of my time to remove my Data Doubler, re-install the old optical drive, and install the firmware update at the risk of damaging a cable or something else with my prized MBP.

        I haven’t had any issues with my 6G SSD…I love it. Has been the best upgrade I’ve ever done to any computer I’ve owned.

        So when you say the firmware provides stability and performance, to what extent? If it provides a 100% performance gain or fixes a critical stability problem, then sure it’s worth the risk for me. If its a marginal performance gain or only address a rare stability issue, then I’ll pass b/c I don’t want to risk messing up a good thing.




        • If your SSD is operating without any issue, we are of the mindset of “if it ain’t broke – don’t fix it.”
          While we do list the new firmware as ‘recommended’, the update is not critical.




  • Do you have a change log?




  • is it true this update will not work if we are using the Data Doubler?
    i read that on the OWC page here at the bottom:
    http://eshop.macsales.com/tech_center/OWC/SSD/6G/Mac